Клуб API Карт

Перестал работать MultiLineString

volegov2
31 октября, 18:44

Перестал работать MultiLineString

Обычный LineString работает

https://jsfiddle.net/hb41n5bn/3/

а MultiLineString нет:

https://jsfiddle.net/gd5agsxs/1/

Кто-нибудь с этим сталкивался?

10 комментариев
Здравствуйте, в публичном JS API нет поддержки мультигеометрий. Обратная совместимость для внутренних сущностей и интерфейсов, не описанных в документации, не гарантируется.


Подскажите, пожалуйста, откуда Вы узнали об этой функциональности.
MultiLineString стандартный тип геометрии, мы просто попробовали его и он работал последние полгода минимум, отвалился сегодня в 15-00 по Москве. Сами удивились что он не был описан в документации. Очень нужный графический примитив, верните его пожалуйста, хотя бы в dev-версию. Тем более что его корни до сих пор остались http://take.ms/h8Kns
volegov2,
спасибо за фичреквест, мы обязательно подумаем, как добавить этот тип геометрии в поддержку для всех пользователей API.
На сегодняшний день, к сожалению, мультигеометрий в API нет и мы крайне не рекомендуем завязываться на непубличные интерфейсы - они могут ломаться или несовместимо меняться.
volegov2,
перейдите на 2.1.55 пока. Я попробовал, у меня работает.
Willie Do,
В том то и дело, что у нас по урлу для 2.1.48 подтягивается 2.1.56 (
Willie Do,
Спасибо! Недогадались поперебирать версии
volegov2,
пожалуйста, обратите внимание, что старые версии со временем отключаются, как описано в документации.
Советуем Вам перейти на использование публичных интерфейсов, иначе есть большой риск, что код снова сломается.
ymapsapi,
Это понятно, но сейчас важнее включить ранее работающий функционал. а дальше думать что с этим делать.
Добрый день! 
Кроме того описание MultiLineString есть для пиксельной геометрии: https://tech.yandex.ru/maps/doc/jsapi/2.1/ref/reference/geometry.pixel.MultiLineString-docpage/
Что наводит его на мысль попробовать в основной.
zetelion,
перейдите на 2.1.55 пока. Я попробовал, у меня работает.