Клуб API Карт

[Решено] Подружить 2.1 с 2.0

ecoatoms
28 сентября 2016, 14:23

Доброго времени суток!

Подскажите, пожалуйста, кто знает, что нужно сделать, чтобы новая, красивая карта, давала возможность работать на одной странице и старой карте?

Вместе с новой в консоле выводится ошибка: 

ymaps.Map is not a constructor

Я бы с удовольствием избавился от старой, но не сейчас, там очень много правок.

4 комментария
Подписаться на комментарии к посту
Тишина, никто видимо не знает. Придётся менять версию старой карты на новую.
Попробуйте подключить 2.1.43 вместо 2.1
Там кажется была проблема при одновременном подключении разных версий
dimik,
2.1 и есть 2.1.43, так как при выборе 2.1 выбирается последняя версия.
Разобрался! Дело было в единственно доступном методе вызова инициализации:
ymaps.ready(initMap);