Функция СУММ и СРЗНАЧ дают ошибку, если в столбце есть #Н/Д. Как это поправить (Excel 2013)?

Анонимный вопрос
  · 470
tDots.ru4,6K
Мы смотрим на бизнес через цифры и знаем, как получить максимум пользы.   · tdots.ru

Используйте функцию АГРЕГАТ. Она умеет пропускать ошибки при подсчетах.

Вот такой вариант вернет сумму диапазона, пропустив ошибки: =АГРЕГАТ(9;6;A1:A15)

А вот такой вариант - вернет среднее: =АГРЕГАТ(1;6;A1:A15)

Комментировать ответ…
Вы знаете ответ на этот вопрос?
Поделитесь своим опытом и знаниями
Войти и ответить на вопрос
Читайте также

Не могу понять, почему в Excel вместо числа появляется дата? Как это исправить?

Кликните правой кнопкой мыши на ячейку, в которой выполняется перевод в дату и выберите "Формат ячеек". В появившемся окне выбирайте или "числовой", или "общий".

18 марта 2019  · 39,8 K
Прочитать ещё 4 ответа

Почему в ячейке Excel отображается формула, а не значение?

Data Analyst. Веду телеграм-канал о презентациях, когда есть свободное время :)  · t-do.ru/fuckmypresentation

Вероятно, включено отображение формул.

Как отключить:

image.png

Также вы можете использовать сочетание клавиш CTRL+` (маленький значок — это значок тупого ударения). Обычно (но не всегда) значок тупого ударения располагается в верхнем левом углу клавиатуры. Чтобы вернуться к стандартному режиму, нажмите эту кнопку еще раз.

Если это не помогло, то можно почитать справку Excel на эту тему.

16 марта 2019  · 62,6 K
Прочитать ещё 1 ответ

Функция ВПР выдаёт ошибку #Н/Д, но если таблицы данных скопировать и вставить заново, то ошибка пропадает.В чём может быть проблема?

Варианты:

  1. Неправильно написана функция. Есть ошибки в аргументах
  2. Отличие исходных данных (ищем число 1450, а в таблице, где ищем, стоит текст '1450
  3. Ретроградный меркурий

Без файла или скриншота не подскажу. Не хочется играть в бабушку Вангу :)

26 июня  · 2,5 K
Прочитать ещё 1 ответ

Как записать две формулы в ячейку в Excel, чтобы обе работали?

Нужно использовать знаки &, пример: =СУММ(A1:A10)&";"&СУММ(B2:B10) в одной ячейке будет 2 разные суммы через точку с запятой.

По этой логике можно вставлять в ячейку не только 2 формулы но и текст и сколько угодно формул.

23 августа 2019  · 25,4 K
Прочитать ещё 1 ответ

Какая формула в Excel (вида "если, то") позволяет возвращать значение другого столбца той строки, где найдено контрольное слово?

Например, имеем таблицу с животными их номерами

1.jpg

Предположим, что мы хотим в желтой ячейке вывести значение из столбца C если в столбце А нам встречается значение "волк".

Пишем туда формулу

=ИНДЕКС($C$1:$C$7;ПОИСКПОЗ("волк";$A$1:$A$7;0))

Получаем результат

1.jpg
17 января  · 51,8 K
Прочитать ещё 1 ответ