tDots.ru
Мы смотрим на бизнес через цифры и знаем, как получить максимум пользы.
Рейтинг за ответы и посты  4 971
tdots.ru
Лента — это вопросы, ответы, репосты пользователей в хронологическом порядке. Если пока вы видите в ней не все публикации, не пугайтесь: скоро мы их аккуратно добавим.

ОЧЕНЬ прошу помощи!? Excel!

Есть задача: два столбца с цифрами, в каждом по пять строк. Необходимо составить формулу, которая бы сравнивала значения в каждой ячейке из одного столбца со значением каждой ячейки в другом... Развернуть
tDots.ru5,0K
Мы смотрим на бизнес через цифры и знаем, как получить максимум пользы.   · tdots.ru  · 25 октября 2020
Решение сильно зависит от версии Excel, в которой вы работаете. Для новых версий (Excel 2019, Microsoft 365) сработает такая формула: =ОБЪЕДИНИТЬ(", ";ИСТИНА;ЕСЛИ(A2:A6=B2:B6;A2:A6;"")) Для более старых версий надо будет писать пользовательскую функцию на языке VBA. Например, такую: F... Читать далее
Компьютерная помощь+2
347

Нужно в конце каждой строки Excel удалить 4 символа. Строчек много. От 600 до 2500. Как это можно сделать?

спрашивает
Райо Валикано

Если можно, то максимально подробно и пошагово опишите. Я в Excel — булка и профан.

tDots.ru5,0K
Мы смотрим на бизнес через цифры и знаем, как получить максимум пользы.   · tdots.ru  · 6 августа 2020
Вводите формулу в первую ячейку соседнего столбца (в формуле ниже предполагается, что у вас первая ячейка с данными - это A1, а формула вводится в B1): =ПСТР(A1;1;ДЛСТР(A1)-4) Затем выделяете ячейку, в которой ввели формулу (в ней будет текст без четырех последних символов). У ячейки в... Читать далее
Комментировать ответ…Комментировать…
Программы+5
1,3 K

Как вставить разрыв страницы в таблице, чтоб заголовки столбцов остались на последующих страницах, кто-нибудь знает? Это возможно?

спрашивает
Pavel Lе

Как вставить разрыв страницы в таблице, чтоб заголовки столбцов остались на последующих страницах, кто-нибудь знает? Это возможно?

tDots.ru5,0K
Мы смотрим на бизнес через цифры и знаем, как получить максимум пользы.   · tdots.ru  · 1 августа 2020

Если будет вставлен разрыв страницы, то таблица тоже будет "разорвана" на две отдельные, никак не связанные между собой. Поэтому опция "Повторять строки заголовков" не сработает. Нужно будет копировать шапку во вторую таблицу вручную.

Word
553

SOS! Нужна помощь в написании формулы из двух условий.

спрашивает
Татьяна Л.
Если А >12130, то должны выполняться условия: 1) сначала из А вычесть 12130 - постоянная цифра, 2) Полученный результат умножить на 10%, 3) к 10% прибавить 2668,6 - постоянная цифра. = ЕСЛИ(B3>... Развернуть
tDots.ru5,0K
Мы смотрим на бизнес через цифры и знаем, как получить максимум пользы.   · tdots.ru  · 29 июля 2020
Правильная формула выглядит вот так: =ЕСЛИ(B3>12130;(B3-12130)/100*10+2668,6; B3*0,22) Так как значение может быть либо больше, либо меньше фиксированного, второй раз указывать ЕСЛИ не обязательно. И вы в своей формуле забыли указать, что 0,22 надо брать от числа в ячейке. И со скобками... Читать далее
Комментировать ответ…Комментировать…
Программирование+3
247

Объединение и сумма выделенных ячеек (Excel)

спрашивает
Михаил Е.

Добрый день!

Как объединить ячейки с суммированием данных.

tDots.ru5,0K
Мы смотрим на бизнес через цифры и знаем, как получить максимум пользы.   · tdots.ru  · 29 июля 2020
Такое можно сделать либо вручную (предварительно подсчитать где-то сумму, затем объединить ячейки, а потом прописать эту сумму в объединенной), либо макросом. Макрос такой: Sub MergeAndSum() If TypeName(Selection) <> "Range" Then Exit Sub Application.DisplayAlerts = False With Selectio... Читать далее
Комментировать ответ…Комментировать…
Программы для пк+2
443

Почему при использовании формулы SUM в ячейке стоит 0?

Может потому что в суммируемых ячейках стоят формулы вместо чисел? Если да то как это можно исправить?

tDots.ru5,0K
Мы смотрим на бизнес через цифры и знаем, как получить максимум пользы.   · tdots.ru  · 29 июля 2020
Вероятно, проблема в том, что вы имеете дело с текстом, а не с числами. Например, если в исходной формуле какое-то число взято в кавычки (например, IFS(A1="iPhone";"100"), то такое число не будет суммироваться (оно считается текстом). Числа нельзя брать в кавычки, их надо указывать без... Читать далее
Комментировать ответ…Комментировать…
Гугл таблицы
1,5 K