Задание#T787

Запишите число, которое будет напечатано в результате выполнения следующей программы.

Бейсик

DIM S, N AS INTEGER
S = 0
N = 75
WHILE S + N < 150
  S = S + 15
  N = N - 5
WEND
PRINT N

Python

s = 0
n = 75
while s + n < 150:
 s = s + 15
 n = n - 5
print(n)

Алгоритмический язык

алг
нач
 цел n, s
 s := 0
 n := 75
 нц пока s + n < 150
  s := s + 15
  n := n - 5
 кц
 вывод n
кон

Паскаль

var s, n: integer;
begin
 s := 0;
 n := 75;
 while s + n < 150 do
 begin
  s := s + 15;
  n := n - 5
 end;
 writeln(n)
end.

С++

#include <iostream>
using namespace std;

int main() {
 int s = 0, n = 75;
 while (s + n < 150) {
  s = s + 15;
  n = n - 5;
 }
 cout << n << endl;
 return 0;
}
Показать разбор и ответ
Это задание взято из демоварианта ФИПИ 2019
1К попыток решения46% решили верно
Яндекс.Репетитор пришёл на смену сервису Яндекс.ЕГЭ, и мы активно собираем отзывы пользователей. Пожалуйста, пишите нам через форму обратной связи.