Личный кабинет

Задание#T787

Запишите число, которое будет напечатано в результате выполнения следующей программы.

Бейсик

DIM S, N AS INTEGER
S = 0
N = 75
WHILE S + N < 150
  S = S + 15
  N = N - 5
WEND
PRINT N

Python

s = 0
n = 75
while s + n < 150:
 s = s + 15
 n = n - 5
print(n)

Алгоритмический язык

алг
нач
 цел n, s
 s := 0
 n := 75
 нц пока s + n < 150
  s := s + 15
  n := n - 5
 кц
 вывод n
кон

Паскаль

var s, n: integer;
begin
 s := 0;
 n := 75;
 while s + n < 150 do
 begin
  s := s + 15;
  n := n - 5
 end;
 writeln(n)
end.

С++

#include <iostream>
using namespace std;

int main() {
 int s = 0, n = 75;
 while (s + n < 150) {
  s = s + 15;
  n = n - 5;
 }
 cout << n << endl;
 return 0;
}
Показать разбор и ответ
Это задание взято из демовариантов ФИПИ 2018-2020
Это задание решали 12 тыс. раз. С ним справились 63% пользователей.

Рекомендованные задания

Для составления персональной подборки решено недостаточно заданий.
Повышайте свой балл на экзамене!
Решать задания
0 баллов сегодня
дней без пропуска

0
пн
0
вт
0
ср
0
чт
0
пт
0
сб
0
вс