Задание#T798

В программе используется одномерный целочисленный массив AA с индексами от 00 до 99. Значения элементов равны 2,4,3,6,3,7,8,2,9,12, 4, 3, 6, 3, 7, 8, 2, 9, 1 соответственно, т.е. A[0]=2,A[1]=4A[0] = 2, A[1] = 4 и т. д.
Определите значение переменной cc после выполнения следующего фрагмента этой программы, записанного ниже на пяти языках программирования.

Бейсик

c = 0
FOR i = 1 TO 9
 IF A(i-1) < A(i) THEN
  c = c + 1
  t = A(i)
  A(i) = A(i-1)
  A(i-1) = t
 END IF
NEXT i

Python

c = 0
for i in range(1, 10):
 if A[i-1] < A[i]:
  c = c + 1
  A[i-1], A[i] = A[i], A[i-1]

Алгоритмический язык

c := 0
нц для i от 1 до 9
 если A[i-1] < A[i] то
  c := c + 1
  t := A[i]
  A[i] := A[i-1]
  A[i-1] := t
 все
кц

Паскаль

c := 0;
for i := 1 to 9 do
 if A[i-1] < A[i] then
 begin
  c := c + 1;
  t := A[i];
  A[i] := A[i-1];
  A[i-1] := t;
 end;

С++

c = 0;
for (int i = 1; i < 10; i++)
 if (A[i-1] < A[i]){
  c++;
  t = A[i];
  A[i] = A[i-1];
  A[i-1] = t;
 }
Показать ответ
Это задание взято из демоварианта ФИПИ 2019
2К попыток решения26% решили верно
Яндекс.Репетитор пришёл на смену сервису Яндекс.ЕГЭ, и мы активно собираем отзывы пользователей. Пожалуйста, пишите нам через форму обратной связи.