Задание 10. Циклический алгоритм о бработки массива чисел, записанный на алгоритмическом языке: все задания

Остальные задачи

Задание#T5720

Школьник делал лабораторную работу по физике, в ходе которой измерил 1010 раз силу тока и записал показания амперметра в таблицу Tok (Tok[1]Tok[1] – результат первого измерения, Tok[2]Tok[2] – второго и т. д.).
Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на пяти языках программирования.
алг
нач
  целтаб Tok[1:10]
  цел k, m
  Tok[1] := 10; Tok[2] := 14
  Tok[3] := 15; Tok[4] := 4
  Tok[5] := 12; Tok[6] := 6
  Tok[7] := 3; Tok[8] := 5
  Tok[9] := 5; Tok[10] := 10
  m := 22
  нц для k от 1 до 10
     если Tok[k] > 10 то
       m := m - 1
     все
  кц
  вывод m
кон
Показать разбор и ответ
Это задание составили эксперты «СтатГрада» для Яндекса
3К попыток решения38% решили верно

Задание#T5740

Школьница делала лабораторную работу по физике, в ходе которой измерила 1010 раз силу тока и записала показания амперметра в таблицу Tok (Tok[1]Tok[1] – результат первого измерения, Tok[2]Tok[2] – второго и т. д.).
Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на пяти языках программирования.
алг
нач
  целтаб Tok[1:10]
  цел k, m
  Tok[1] := 10; Tok[2] := 14
  Tok[3] := 15; Tok[4] := 4
  Tok[5] := 12; Tok[6] := 6
  Tok[7] := 3; Tok[8] := 5
  Tok[9] := 5; Tok[10] := 10
  m := 0
  нц для k от 1 до 10
     если Tok[k] > 6 то
       m := m + 2
     все
  кц
  вывод m
кон
Показать разбор и ответ
Это задание составили эксперты «СтатГрада» для Яндекса
2К попыток решения41% решили верно

Задание#T5760

В таблице Work хранятся данные о количестве заказов, принятых фирмой «Алоэ» с 11 по 1515 ноября. (Work[1]Work[1] – число заказов, принятых 11 ноября, Work[2]Work[2]22 ноября и т. д.).
Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на пяти языках программирования.
алг
нач
  целтаб Work[1:15]
  цел k, m
  Work[1] := 5; Work[2] := 4
  Work[3] := 5; Work[4] := 7
  Work[5] := 6; Work[6] := 12
  Work[7] := 7; Work[8] := 3
  Work[9] := 9; Work[10] := 7
  Work[11] := 0;Work[12] := 9
  Work[13] := 1;Work[14] := 0
  Work[15] := 8
  m := 0
  нц для k от 1 до 15
     если Work[k] < 7 то
        m := m + 1
     все
  кц
  вывод m
кон
Показать разбор и ответ
Это задание составили эксперты «СтатГрада» для Яндекса
2К попыток решения50% решили верно

Задание#T5780

В таблице Work хранятся данные о количестве заказов, принятых фирмой «Конфетти» с 11 по 1515 декабря. (Work[1]Work[1] – число заказов, принятых 11 декабря, Work[2]Work[2]22 декабря и т. д.).
Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на пяти языках программирования.
алг
нач
  целтаб Work[1:15]
  цел k, m
  Work[1] := 5; Work[2] := 4
  Work[3] := 5; Work[4] := 7
  Work[5] := 6; Work[6] := 12
  Work[7] := 7; Work[8] := 3
  Work[9] := 9; Work[10] := 7
  Work[11] := 0;Work[12] := 9
  Work[13] := 1;Work[14] := 0
  Work[15] := 8
  m := 0
  нц для k от 1 до 15
     если Work[k] > 6 то
       m := m + 1
     все
  кц
  вывод m
кон
Показать разбор и ответ
Это задание составили эксперты «СтатГрада» для Яндекса
1К попыток решения50% решили верно
Яндекс.Репетитор пришёл на смену сервису Яндекс.ЕГЭ, и мы активно собираем отзывы пользователей. Пожалуйста, пишите нам через форму обратной связи.