Анонимный вопрос
10 месяцев назад
1 401

Как можно подсчитать количество слов в ячейке Excel?

2 человека оценили этот вопрос
Интересный вопрос
Ещё никто не написал развернутый ответ, соответствующий правилам сервиса.
Мы смотрим на бизнес через цифры и знаем, как получить максимум пользы.

Например, вот так:

=ДЛСТР(СЖПРОБЕЛЫ(A1))-ДЛСТР(ПОДСТАВИТЬ(СЖПРОБЕЛЫ(A1);" ";""))+1

123

Не хватает добавки для пустых ячеек, т.е. когда количество слов 0, эта формула дает 1, чтобы включить и отсутствие слов нужно писать так:

=ЕСЛИ(ДЛСТР(А1)>0;ДЛСТР(СЖПРОБЕЛЫ(A1))-ДЛСТР(ПОДСТАВИТЬ(СЖПРОБЕЛЫ(A1);" ";""))+1;0)

31
Написать комментарий

0/140Ответ не может быть меньше 140 символов