Клуб API Карт

API Яндекс.Карт версия 2.0.9

tekunova
7 июня 2012, 15:27
API Яндекс.Карт версия 2.0.9
Опубликована новая версия API Яндекс.Карт. Она доступна по адресу api-maps.yandex.ru/2.0. Если вы хотите продолжить использование предыдущей версии, указывайте api-maps.yandex.ru/2.0.8.

Добавлено:
— Пакет package.overlays, содержащий пиксельные геометрии и оверлеи.
— Опции hasBalloon и hasHint для слоев активных областей.
— Опция shadowPane для геообъектов.
— На кластеризаторе можно ловить события кластеров.

Исправлено:
— Не применялись стили геообъекта для редактора ломаных и многоугольников.
— Ошибка в iOS 3.1.3.
— Не применялись опции геометрий в методе getPixelGeometry.
— Исключение при удалении включенной панели пробок.
— Ошибка в методе removeAll кластеризатора.
— Неправильная работа опции iconShadowOffset.
— Неправильная работа опции clusterIconLayout.
— Неправильный расчет расстояний линейкой при порядке координат lat-long.
— Ошибка в IE7 при большом количестве видимых на экране тайлов.
— Ошибка в IE при удалении графики.
— Работа кода Конструктора схем проезда в Opera.

Другое:
— Для IE9 отключены CSS transitions из-за некорректного рендеринга.

Команда разработчиков API Яндекс.Карт.
0 комментариев
Подписаться на комментарии к посту