Клуб API Карт

API Яндекс.Карт версия 2.0.38

a.chebotareov
3 июня 2014, 15:53

Сегодня опубликована новая версия API Яндекс.Карт — 2.0.38 с обновленным модулем Регионы. Она доступна по адресу api-maps.yandex.ru/2.0.38. В четверг, 10 июня, мы переключим на нее api-maps.yandex.ru/2.0 и api-maps.yandex.ru/2.0-stable.

API Яндекс.Карт версия 2.0.38

Несмотря на релиз версии API Яндекс.Карт 2.1, мы продолжаем поддерживать прошлые ветки API. Сегодня мы опубликовали новую версию API Яндекс.Карт — 2.0.38 с обновленным модулем Регионы. Она доступна по адресу api-maps.yandex.ru/2.0.38. В четверг, 10 июня, мы переключим на нее api-maps.yandex.ru/2.0 и api-maps.yandex.ru/2.0-stable.

Пожалуйста, прочтите статью о системе версионирования API.

Добавлено:

— Поддержка дисплеев высокой четкости в части подложки карт.

Изменено:

— Обновлен модуль Регионы.

Исправлено:

— Некорректная сортировка меток в балуне кластера, если часть заголовков меток была задана числами.

— В IE 10-11 при долгом нажатии на контейнер карты появлялось контекстное меню. 

— Задание стиля line-height на странице могло приводить к ошибкам отображения элементов управления.

— Переполнение стека при подписке на ymaps.ready внутри другого обработчика ymaps.ready. 

— В некоторых ситуациях показывались неправильные подсказки к пробкам.

— Ошибка при разборе запроса в geoQuery.search, если знак равенства не был отбит пробелами.

— Ошибки в браузерах IE и Safari Mobile.

— Не работала опция tremor в behavior.Drag.

— Переполнение стека в некоторых ситуациях при клике в mapTools.

— Исключение при попытке динамически задать опцию overlayFactory в IE 9-11.

Команда разработчиков API Яндекс.Карт