Клуб API Карт

Косяк в ie6-7-8

ktotud
18 мая 2012, 13:26

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"

    "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

html xmlns="http://www.w3.org/1999/xhtml">

<style> 

 html { height: 100% }

 body { height: 70%; margin: 0px; padding: 0px }

 #map { height: 100% }

</style>

<script src='http://api-maps.yandex.ru/2.0/?load=package.full&lang=ru-RU' type='text/javascript'></script>

 

  <script type='text/javascript'>

   ymaps.ready(init);

   function init () {

    var iMap = new ymaps.Map('map', {center: [56.850985, 53.207629], zoom: 12 }

   }</script>

 <body>

<div id=map style='width:100%; height:100%'></div>

</body>

</html>

 

 

- выдает Stack overflow at line 0

 

 

делаем  body { height: 60%; margin: 0px; padding: 0px } 

и меньше - ошибок нет

 

в 9 ие ошибок нет совсем

9 комментариев
Подписаться на комментарии к посту

У вас чистые ие? Я попробовала пример в ие9 в режиме ие8 - все работает корректно.

а вы не в режиме пробуйте - а в реальном . Проверяли на нескольких компах. 

 

http://torwald.ru/72/portable-%D0%B2%D0%B5%D1%80%D1%81%D0%B8%D0%B8-%D0%BE%D1%81%D0%BD%D0%BE%D0%B2%D0%BD%D1%8B%D1%85-%D0%B1%D1%80%D0%B0%D1%83%D0%B7%D0%B5%D1%80%D0%BE%D0%B2/

 

вот линк на браузеры без установки

Спасибо, у нас свой зоопарк есть)

На чистом ие6 работает корректно, на ие6 под виртуалкой тоже.

На всякий случай напишу пример, который тестирую - может что-то не так задаю.

http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

http://www.w3.org/1999/xhtml">

 

 

Попробовала на разных мониторах - на большом, и на мелком - все работает.

В общем ситуация такая, что первый раз грузит нормально -  иногда на второй раз или на третий выдает ошибку при перезагрузке страницы... такое ощущение что чтото не успевает подгрузится....

 

http://igis.ru/1.html

Какая у вас версия браузера и какое разрешение экрана?

Бага зафиксированная, зависит от размеров карты. Копаем.

просто 70% - не пойдет, тут надо чтобы это 70% были для окна раскрытом на fullHD.

 

х.з. у меня тут 1280х1024.... там  не точно 70% а от 70 до 100

меньше 70 как повезет - на 60 уже не выдает....

Да, как выяснилось проблемма исключительно в колличестве отображаемых тайлов.

Точные замеры не проводил - у меня падает на 40 видимых тайлах.

Фикс уже готов, но к вам прийдет не раньше выхода новой версии АПИ.