Клуб API Карт

Грузится последняя версия API вместо указанной

alexip74
26 октября 2012, 09:29

Что-то 2.0.15 совсем расстраивает.

 

Явно гружу:

<script src="http://api-maps.yandex.ru/2.0.10/?load=package.full&lang=ru-RU" type="text/javascript" charset="utf-8"></script>

 

Получаю глюк геокодера - "Москва г" не находит.

 

Смотрю в отладчик Хрома и вижу:

init('ymaps','http://api-maps.yandex.ru/2.0.15/release/',false,'package.full',project_data,'ymaps2_0_15','')

 

Почему вдруг тянется 2.0.15 вместо 2.0.10?

 

И еще гляжу encodeURIComponent() перестал любиться яндексом. Полгода любился (без него в MSIE в режиме не UTF иначе карты не работали) и вдруг йок. Точнее даже не йок, а внутри геокодера он совершенную лажу выдает. Типа Братиславы вместо Ивановской области.

1 комментарий
Подписаться на комментарии к посту

1. Старые версии АПИ рано или поздно удаляются, ссылки на них становятся алиасами 2.0-stable

2. Геокодер никак не зависит от версии API, это внешний сервис. Опишите подробнее возникающие проблемы, мы попытаемся понять, в чем дело.