Клуб API Карт

Неправильный ключ в IE в FF всё ОК...

startext
23 мая 2009, 19:36

В IE выдаёт сообщение неправильный ключ и соответственно не грузит карту. В подробностях ошибки пишет YMaps - определение отсутствует...

IE8, но семёрка себя так же ведёт... FF отображает без проблем. Причём, что самое любопытное, это происходит периодически!!!

Кто-нибудь в курсе где рыть?

12 комментариев
Подписаться на комментарии к посту
paranoik-vasilii
23 мая 2009, 19:46

а в url случаем нет русскийх букв

Случайно есть. Может из-за этого? Но почему интересно периодически?!
paranoik-vasilii
24 мая 2009, 08:43

именно из-за этого
я не знаю чей баг, IE или яндекса, но IE время от времени передаёт русский буквы в Unicode, а яндекс, при анализе, зачем-то лезет дальше доменного имени и видя этот Unicode ломается

Дайте пожалуйста пример такого урла. Постараемся локализовать проблему.
Я уже изменил урлы на латиницу. Но есть ещё в кэше поисковиков. Там тоже эту ошибку шестёрка выдаёт:
http://209.85.129.132/search?q=cache:TCc28TR7woEJ:www.sanyo.in.ua/%D0%90%D0%B1%D1%81%D0%BE%D1%80%D0%B1%D1%86%D0%B8%D0%BE%D0%BD%D0%BD%D1%8B%D0%B5-%D1%87%D0%B8%D0%BB%D0%BB%D0%B5%D1%80%D1%8B-sanyo/index.html+site:sanyo.in.ua&cd=3&hl=ru&ct=clnk&gl=ua
Хотя нет, сорри... В кеше то оно и должно выдвать, что ключ не правильный, он ведь с другого сайта оторбажается...
если получится повторить то обязательно пишите
спасибо
проблема понята и принята
будем исправлять
У меня аналогичная проблема. Подскажите пожалуйста была ли решена данная проблема??... 
На всякий случай, вот кодировка страницы:
pageEncoding="UTF-8"%>
 
Дайте пожалуйста ссылку на страницу с проблемой.