Клуб API Карт

API 2.1 или сила природы....

igdev
17 октября 2013, 11:55

Попробовал свои карты на 2.1 перенести... не, ну оно конечно переносится, но как-то очень странно:)

 

<script src="jquery-1.7.2.min.js" type="text/javascript"></script>
<script src="http://api-maps.yandex.ru/2.1-dev/?lang=ru-RU&load=package.full" type="text/javascript">

 

или так

<script src="http://api-maps.yandex.ru/2.1-dev/?lang=ru-RU&load=package.full" type="text/javascript">
<script src="jquery-1.7.2.min.js" type="text/javascript"></script>

далее стандартные мои скрипты работы с картами.... многое не работает

 

а если вот так

 <script src="jquery-1.7.2.min.js" type="text/javascript"></script>
 <script src="http://api-maps.yandex.ru/2.1-dev/?lang=ru-RU&load=package.full" type="text/javascript">
 <script src="jquery-1.7.2.min.js" type="text/javascript"></script>

работает все.... 

Я в ступоре)))

4 комментария
Подписаться на комментарии к посту
Очень сложно что-либо подсказать без кода и ошибок из консоли.
Скорей всего инициализации карты неправильно происходит.
Есть публичная ссылка?

Да пожалуйста, вот временно положил кастрированную часть, чтобы чисто проблему показать

http://igordev.ru/Devices/atest1.html рабочая

http://igordev.ru/Devices/atest.html нерабочая

Различия как и писал выше.

Т.е. я поддключаю свой скрипт в котором в данное время 1 переменная инициализируется, она видна либо она не видна из основного файла. Как-то странно все это или что-то не понимаю.

 

Все-таки это сила природы )

Ты забыл закрывающий тег в строчке подключения АПИ 

Да.... дела.... Спасибо большое!