Клуб API Карт

package.standard не работает, а package.full работает

Пост в архиве.
nazar-pc
13 февраля 2014, 00:08

Вот так

<script src="//api-maps.yandex.ru/2.1-dev/?lang=ru-RU&load=package.standard&lang=ru-RU"></script>

получаю

Error: Can't resolve required module "package.standard"
...oint","8w",")-8m8y8x"],["geometryEditor.controller.PointDragging","8x",")-8n8f"]...
?lang=...g=ru-RU (рядок 5)
5 комментариев

Модульность в 2.1 будет анонсирована в обозримом будущем, следите за анонсами.

Хорошо бы, а то сайт с картой и не такой большой логикой валит Safari на iOS на не самых новых устройствах, видимо, не хватает памяти.

Всеволод Шмыров
28 января 2016, 00:41
Проблема и сейчас наблюдается? Какая версия iOS?

Наблюдалась дня 2 назад, сейчас под рукой устройства нет.

iOS 6.x на iPhone 3GS, iPod 4

А на последнем iPad, который ещё не Air иконки кастомные через секунду после масштабирования расплываются в ширину.

Всеволод Шмыров
28 января 2016, 00:41
В версии 2.1 сейчас нет каких пакетов кроме package.full. Этот же пакет будет загружаться если не указать параметр load. Размер package.full был уменьшен за счет того, что некоторые части API загружаются по требованию (при открытии балуна, к примеру, загружается его макет). Других способов загрузки пока нет, но как сказал Бетмен, скоро будут анонсированы.