Клуб API Карт

Не подгружаются элементы управления при подгрузке карты функцией

bonart-maxim
3 июня 2014, 15:40

Пишу вот такой код.
По идее должны появится элементы управления, но их нет. Почему?

Использую карту http://api-maps.yandex.ru/2.0/?load=package.full&lang=ru-RU

 


function hotel_map(){
        if(myMap) myMap.destroy();
       
        ymaps.ready(init);
        var myMap,
            myPlacemark;
   
        function init(){     
            myMap = new ymaps.Map("hotel-map", {
                center: [, ],
                zoom: 7,
                behaviors: ['scrollZoom', 'fullscreenControl'],
                controls: ['zoomControl', 'typeSelector',  'fullscreenControl']
            });
   
            myPlacemark = new ymaps.Placemark([, ], {
                balloonContentHeader: "",
                balloonContent: ''
            });
           
            myMap.geoObjects.add(myPlacemark);
           
            myMap.behaviors
            .enable('ruler');
        }   
    }

 

5 комментариев

center: [, ],

?

вот правильный вариант, он тоже не работает.
function hotel_map(){
        if(myMap) myMap.destroy();
       
        ymaps.ready(init);
        var myMap,
            myPlacemark;
   
        function init(){     
            myMap = new ymaps.Map("hotel-map", {
                center: [44.671437, 34.409637],
                zoom: 7,
                behaviors: ['scrollZoom', 'fullscreenControl'],
                controls: ['zoomControl', 'typeSelector',  'fullscreenControl']
            });
   
            myPlacemark = new ymaps.Placemark([44.671437, 34.409637], {
                balloonContentHeader: "Гостиница «Пещера»",
                balloonContent: '',
                balloonContentFooter: 'Россия, Крым, Алушта, Центральная Алушта, ул. Горького, 6'
            });
           
            myMap.geoObjects.add(myPlacemark);
           
            myMap.behaviors
            .enable('default');
        }   
    }

Поле controls можно указывать начиная с версии 2.1

в 2.0 оно еще не поддерживается

http://api.yandex.ru/maps/doc/jsapi/2.0/ref/reference/Map.xml

да, спасибо, работает.
Не обратил внимания.

надыть где-то написать что fullscreenControl поддерживается начиная с 2.1