Клуб API Карт

Ключи для работы с API Яндекс.Карт версий 1.х больше не нужны

a.chebotareov
31 октября 2014, 13:44

Мы отключили обязательные ключи для старых версий API 1.х. Теперь, если вы используете версию API 1.x, указывать ключ в ссылке подключения не обязательно.

Менять ссылку, удаляя из нее ключ, тоже не требуется — API будет работать со старыми ключами. 

Форма получения нового ключа больше не доступна.

20 комментариев
Подписаться на комментарии к посту

То есть если возникает ошибка ключа для домена, достаточно просто удалить ключ, или как? Возникла проблема при переносе на другой домен и кодер, писавший скрипт более не доступен. Как мне быть? Спасибо.

Просто удалите &key= из строки подключения апи.

На WordPress плагин Yandex Maps требует ключ, без ключа не работает. Что делать?

Оставлять пустое поле и смотреть в ссылке подключения, чтобы не было параметра: &key=. А также посмотрите на новые плаигны для WP, они работают под версией API 2.0 и 2.1 — https://tech.yandex.ru/maps/jsapi/

Спасибо!

Действительно, после удаления key= в ссылке просмотр на карте начинает работать, но (!) определение координат начинает выдавать ошибку "invalid key" 

Определение координат – это геокодер? Там тоже надо удалить полностью параметр ключ, а не только сам ключ. Геокодер уже давно может работать без ключей.

Да, совершенно верно. Параметр key= удален полностью везде, отображение работает прекрасно, как и работало с ключем ранее. Ошибка получается при стандартном вызове определения по адресу через вызов обработчика: 

YMaps.Events.observe(geocoder, geocoder.Events.Fault, function (geocoder, errorMessage) {

    alert("Произошла ошибка (Events, observe): " + errorMessage)

});

текст ошибки - invalid key
Пришлите пожалуйста адрес, страницы, где воспроизводится ошибка.
Воспроизвели, разбираемся. Спасибо за сообщение.

Спасибо огромное.

Я тоже страничку подготовил (что бы осталось только по теме) - может поможет: 

http://195.13.243.213/pm1/admin/t.html

 

Коллеги,

 

со всем уважением, но не смогли бы Вы сориентировать - нам ждать исправлений или уже начать переход на версию 2 (чего сейчас, честно говоря, очень бы не хотелось)

 

Спасибо за ответ заранее

Да. Исправления будут. Но рассмотреть переход на 2.1 все-таки стоит.

Фикс выехал 12.11.2014, 14:29

Проверьте, пожалуйста.

Спасибо огромное! Работает!

Возникла проблема на joomla, используем элемент zoo flyleaf_ymaps.
Раньше просто с геокодера выбирал координаты метки и все работало.
Сейчас появились координаты центра карты с 2 значениями и координаты метки с 2 значениями. Ни то ни то не отображает карту, выдает голубей экран. Удалил API ключи, тоже не помогает :(
Спасибо большое. Исправляем.

Это всё, конечно же, классно, но есть один нюанс и один вопрос:

один нюанс: без удаления ключа из ссылки карта не работает, а только лишь выдаёт алерт о неправильном ключе.

один вопрос: если вы могли отключить обязательные ключи, почему вы не сделали это гораздо раньше?

У меня чуть психика не нарушилась, пока я заливал правки с локалки в инет(и наоборот) и всё время приходилось менять этот ключ с версии для локалки на инет-версию проекта и обратно, потому что вышеописанный "алерт" так напрягал)))

А так сервис, конечно же, классный) Молодцы!

Спасибо. Раньше не получилоась. Без удаления ключа должно работать, если ключ верный.