Клуб API Карт

Переключение 2.1

a.chebotareov
13 ноября 2014, 13:04

Мы переключили api-maps.yandex.ru/2.1 на версию API 2.1.17. Если вы хотите продолжить использование предыдущей версии, указывайте api-maps.yandex.ru/2.1.16

Пожалуйста, прочтите статью о системе версионирования API.

Команда разработчиков API Яндекс.Карт.

22 комментария
Подписаться на комментарии к посту

Уважаемая команда разработчиков!

Хочу обратить ваши внимание на один неприятный баг, появившийся сегодня. При использовании карты, она не загружается, а появляется только надпись яндекс, но если ее увеличить-уменьшить, то тогда она проявляется. В вашей песочнице так же: https://tech.yandex.ru/maps/jsbox/2.1/object_manager_events

Спасибо, будем разбираться

Вроде должно починиться

пока нет..(

Очистите кеш браузера

помогло, теперь все хорошо)

В версии 2.1.17 не отображаются метки

Можете прислать ссылку на страницу, где воспроизводится проблема?

ругается (Объект не поддерживает свойство или метод "querySelector") в конструкторе Map. В версии 2.1.16 конструктор работает без проблем.

Можете описать проблему подробнее? Идеально было бы дать ссылку на страницу, где воспроизводится баг

у меня показывается пустая страница из-за некорректного размера элемента с картой, ошибок в консоли нет (смотрю в нативном ие9)

 

Кстати, вы выставляете на странице doctype ? Без него работать не будет

за doctupe - спасибо.

С IE9 ошибся.

Не работает в IE7.

Ааа, так мы и не поддерживаем ie7 в 2.1 =)

:-)

ну вот и предел IE7.

но 2.1.16 ещё работал.

 

Спасибо.

Подскажите пожалуйста, API 2.0 ещё какое время будет поддерживать

Мы поддерживаем ее и версии 1.х и пока не собираемся отказывать от их поддержки.

Вы про версию вообще или про поддержку конкретно ие7?

Я про версию API 2.0.

на этой версии скрипт работает под IE7.

Или есть вероятность что и API 2.0 перестанет работать под IE 7?

 

Тогда может вопрос правильней поставить:

API 2.0 тоже не поддерживает IE7.

Простите пожалуйста: не нашол где можно почитать про поддержку версий IE версиями API карт.

API 2.0 не перестанет работает под IE7. Страница со списком поддерживаемых браузеров временно утеряна из-за переезда сайта документации, скоро вернем ее назад)

Комментарий удалён

Нет. Только в пикселях.

Так можно, но не задать в процентах размер.