Клуб API Карт

YMaps и prototype.js

tzirulnicov
22 августа 2009, 18:12
Необходимо одновременное использование на странице библиотеки prototype.js (1.6.0.3) и Яндекс.Карт.  Как? При загрузке вылезает element.dispatchEvent is not a function и security error (prototype.js). Если использовать либо ЯК, либо p-e.js, ошибок нет.
9 комментариев
Подписаться на комментарии к посту
API Яндекс.Карт работает совместно с prototype.js.
Последнюю ли версию prototype Вы используете?

Дайте ссылку на страницу.
Я использую последнюю стабильную версию prototype.js - 1.6.0.3, с которой API Яндекс.Карт отказывается работать, что наглядно продемонстрировал на данной странице:

http://anapia.ru/ymaps.html

Вопрос - как решить проблему, если мне необходимо одновременное использование на моей странице Яндекс.Карт и библиотеки prototype.js (1.6.0.3) ?
всё работает нормально
Посмотрел в FF 3.x, Opera 9.6x, IE 6.x. Ошибок не обнаружил.

Повторяется ли проблема? Очистите кэш браузера, возможно, что проблема в этом.
А как сделать, чтобы и в FF2 работало? :)
Спасибо!
Проблема наблюдается в браузерах Firefox 2 и Opera 9.27.
Проблемы можно избежать, если подключать сначала API Яндекс Карт, а потом Prototype.
А ларчик-то просто открывался! :-)

Спасибо большое!