Клуб API Карт

API 2.1 и YMapsML

amalayrev
23 декабря 2014, 02:40

Всем привет,

я не могу разобраться, как заставить работать xml файл с API 2.1. В частности, в шапке страницы я пишу

 <script src="http://api-maps.yandex.ru/2.0/?load=package.full&lang=ru-RU" type="text/javascript"></script> 
<...> 
 ymaps.geoXml.load("http://site.com/database.xml")
 .then(function (res) {
 res.geoObjects.each(function (item) {
 addMenuItem(item, myMap);
 });
 },
 function (error) { alert("При загрузке YMapsML-файла произошла ошибка: " + error); });

Все работает с API 2.0, но когда я меняю первую строку на

 <script src="http://api-maps.yandex.ru/2.1/?load=package.full&lang=ru-RU" type="text/javascript"></script> 

карта не загружается.

Может, кто-нибудь знает, в чем может быть проблема?

Alex

3 комментария
Подписаться на комментарии к посту

Наверное консоль браузера знает. Не пробовали смотреть?

а вообще надо ссылку прикладывать или там пример на jsfiddle.net

Удалось решить проблему с переходом на 2,1? У меня такая же проблема

Нет, к сожалению, вопрос все еще актуален, пока не было времени в нем разбираться