Клуб API Карт

Переключение 2.1

ymapsapi
19 февраля 2015, 18:00

Мы переключили api-maps.yandex.ru/2.1 на версию API 2.1.20. Если вы хотите продолжить использование предыдущей версии, указывайте api-maps.yandex.ru/2.1.17

Пожалуйста, прочтите статью о системе версионирования API.

Команда разработчиков API Яндекс.Карт

31 комментарий
Подписаться на комментарии к посту
Скажите, пожалуйста, мог ли в результате обновления на 2.1.20 тут https://tech.yandex.ru/maps/jsbox/2.1/balloon_and_hint (а также у нас на проекте) перестать отображаться балун карты? (который myMap.balloon.open(...))
Доброе утро! В примере как раз сейчас и подключается версия 2.1.20. Там сейчас все работает (под картой корректно отображается "Содержимое балуна"). Могли бы вы дать ссылку на страницу с проблемой?
О, и правда, извините :)
А ссылку не дам, сами тогда сначала поковыряем.
Спасибо!

Возникла такая же проблема, прописали версию 2.1.17 вместо 2.1 и все стало работать.

P.S.: у нас балуны не вызываются из javascript, а берутся из xml

Пример можете показать?

http://beta-widget.37points.ru/scope

Зеленая кнопка.

А тут уже с версией 17 

http://widget.maxima-express.ru/scope

А можно собрать минимальный пример или хотя бы код деобфусцировать?

С какой целью? ))

Чтобы мы могли найти, в чем ошибка.

Напишите, пожалуйста мне в личку. skype: romvas

Добрый день!

У меня аналогично метки грузятся из xml и внезапно (видимо в связи со сменой API) перестали открываться балуны на карте...

Пример: http://doroga.spbauto.org/show_map_id.php?id=25

Откатываться до 2.1.17 версии, или надо что-то поменять?

Спасибо!

Пока переключитесь на 2.1.17, на неделе разберемся :)

Аналогичная проблема: http://www.fish-hook.ru/articles/filter/mesta,platnaya-rybalka;/

Шаблоны балуна хранятся в layout.storage. Если обращаться к шаблонам напрямую балуны отображаются корректно.

В 2.1.17 все работает корректно. Информация подтягивается через ObjectManager. 

Исправили в 2.1.22, проверяйте
http://clubs.ya.ru/mapsapi/replies.xml?item_no=55422

Работает, спасибо. Когда планируете сделать доступной 2.1.22 по мажорной версии?

Исправили в 2.1.22, проверяйте
http://clubs.ya.ru/mapsapi/replies.xml?item_no=55422
Исправили в 2.1.22, проверяйте
http://clubs.ya.ru/mapsapi/replies.xml?item_no=55422

В FireFox 33.0.2 перестали показываться метки (Placemark) - место под них есть, при наведении хинт показыватся, а вот самой стандартной картинки метки нет (как будто прозрачная). При возврате к 2.1.17 - все ок.

 

 

Исправили в 2.1.22, проверяйте
http://clubs.ya.ru/mapsapi/replies.xml?item_no=55422

Да, в 2.1.22 метки появились - неплохо бы это добавить в 2.1 - на нем много сайтов и не хочется везде править на 2.1.22 :))

Во вторник переключим.
при переходе на страницу https://pogoda.yandex.ru/ для любого города у меня в браузере Mozilla Firefox версии 45.0.1 постоянно подвисает браузер и не реагирует ни на что, пишет:

Похоже, исполняемый на этой странице сценарий занят или не отвечает.
Вы можете остановить его сейчас, открыть сценарий в отладчике или позволить сценарию продолжить свою работу.
Сценарий: https://api-maps.yandex.ru/2.1…?lang=ru_RU...

Пишет очень долго сообщение: передача данных с api-maps.yandex.ru

можно ли исправить?
Спасибо.
jprogrammer,
Добрый день. Проблема только на сайт погоды или на всех остальных сайтах с апи карт тоже? Можете сказать какая у вас ОС?
v.shmyroff,
Добрый вечер,
ОС: Windows 2003 Server SP2, в основном проблема на сайте погоды на https://yandex.ru/maps/ тоже такая же проблема,
похоже действительно проблема именно с API Яндекс карт.
На других сайтах не замечал
v.shmyroff,
проблема началась недавно, где то около месяц назад, до этого все работало без проблем
jprogrammer,
К сожалению, проблема как раз в устаревшей ОС. Совсем недавно Firefox отключил поддержку https сертификатов, которые были подписаны при помощи SHA-1 из-за низкой надежности последних. Это вынудило сайты, которые используют https перейти на более современные методы подписания сертификатов. Но они работаю в Window начиная кажется с Vista.
https://blog.mozilla.org/security/2015/10/20/continuing-to-phase-out-sha-1-certificates/
v.shmyroff,
я сам недавно покупал SSL сертификат и настроил его в nginx с отключением всех ненадежных алгоритмов, и у меня нет проблем с моим сайтом для которого я покупал, а с API Яндекс карт есть проблемы
v.shmyroff,
кроме того у меня карты показываются на странице, т.е. нестыковка у вас если бы сертификат был отключен, по идее карты вообще бы не показывались - верно?
А у меня идут именно тормоза до 10 секунд при открытии страниц, где есть Яндекс карты.

Вот это скрипт у меня открывается без предупреждений с зеленой строкой в браузере: https://api-maps.yandex.ru/2.1/?lang=ru_RU

У вас именно скрипт тормозит на странице, а не загрузка скрипта с вашего ресурса
v.shmyroff,
Вывод: мне просто придется отказаться от сервисов, где есть Яндекс карты, в частности придется пользоваться сервисами подобными gismeteo.
Так уже у меня было с Яндекс поиском:
из-за частой капчи, при том том что я в первый раз за день вводил поисковую фразу у меня она всегда вылезает, мне пришлось перейти на гугл поиск полностью.
При заходе на любую страницу, где есть карта, буквально через пару секунд начинается переход на https://api-maps.yandex.ru/services/inception/?lang=ru_RU&iframe_id=8275&url=%2Fmap&api_version=2.1.42 (возможно, что-то в адресах меняется, так как страницы с картами на разных сайтах, я сохранила только последнюю ссылку, но принцип один). Браузер Firefox 47.0.1. Как от этого избавиться?
litera00,
у вас случайно не стоит дополнение friGate для Firefox? У меня тоже была данная проблема и отключение этого дополнения вроде как помогло.