Клуб API Карт

Это что за ересь?

skier2006
7 апреля 2015, 15:01

Всем привет!

в 10-м Explorer-e набираю maps.yandex.ru и вижу

Ваш браузер устарел. Пожалуйста, обновите браузер (подробнее) или установите  Яндекс.Браузер

Это что за фокусы, господа?

10-й Explorer для Яндекса.Карт старый уже ?!

 

14 комментариев
Подписаться на комментарии к посту
Прочитайте, пожалуйста, то, что написано по ссылке подробнее.

Проклятье! *бьётся головой об стену, прочитав новости*

В своё время на вашем API-карт второй версии написали для 1С систему онлайн-мониторинга движения маршрута. Хочу сказать, были счастливы: техподдержка терпеливо объясняела тонкости синтаксиса, обновляла страницы хэлп по результатам общения с пользователями. Особенно радовало то, что при выходе второй версии API, первая версия всё ещё работало (у того же Google сетарая версия API в один день просто перестала работать).

Сейчас выскочило это памятное сообщение и... это для нас кошмар. Дело в том, что 1С без танцев с бубном и принесения в жертву девственниц работает только... с IE6. Да-да, с IE6. Скажите, быть возможность залочить с нашей стороы вызов вашего API на какой-нибудь из старых версий той же двойки (кажется, мы писали структуру, вызывающую всегда последнюю версию), чтобы эта проблема исчезла, или же предыдущие релизы API 2 (например, API 2.0) скоро будут сняты с поддержки.

В платной версии API сообщение не показывается.
Если вы пользуетесь обычной версией API, свяжитесь с коммерческим департаментом для приобретения лицензии, т.к. вы нарушаете пункты 2.3.2 и 2.3.7.3 пользовательского соглашения
https://feedback2.yandex.ru/api-maps/commercial/
https://legal.yandex.ru/maps_api/

Пункт 2.3.2 точно не нарушаем: это приложение для внутреннего использования и мы его никому не продаём и не получаем за распространение денег. С 2.3.7.3, похоже, всё уже печально.

В любом случае, департаментом свяжусь, а там посмотрим, приобретать лицензию или перепиливать на GWX.

> это приложение для внутреннего использования и мы его никому не продаём и не получаем за распространение денег.

Это не важно, сам факт недоступности извне является нарушением ПС.

Хотелось бы знать сразу, покуда шаблон договора ещё не прислали, есть какие-нибудь плюс от использования коммерческой версии, помимо самого снимания запретов на использования яндекс-карт в системах мониторинга транспорта? И, да, я что-то не нашёл информации по ценам, зато нашёл пугающую информацию на ограничение количества запросов (вроде бы, только к геокодеру и к маршрутизатору, которые у нас в критических системах свои). Есть ссылка на более подробную информацию по коммерческому предложению? 

Я не представитель коммерческого департамента и на ваши вопросы ответить не могу, к сожалению.

Читал я всё это.

Вы это серьёзно?!

Т.е. IE10 у Яндексовских программеров поддерживается частично?!

Или это скрытый способ перетащить людей на Яндекс.Браузер?

(Уберите это позорное сообщение, или, дайте возможность  его отключить из API) 

Поучитесь у Гугла...а?

http://caniuse.com/#compare=ie+10,ie+11

Поддержка IE10, который был выпущен два с половиной года назад, стоит существенных ресурсов, как в смысле исправления нами специфичных для этого браузера багов, так и в плане невозможности разрабатывать новую функциональность (например, в силу отсутствия в этом браузере WebGL). Мы предпочли бы потратить эти ресурсы с большей пользой.

Что касается возможности отключить сообщение из API, то она есть.
http://clubs.ya.ru/mapsapi/replies.xml?item_no=56294

А что если меня не очень интересуют новые фичи в api и всякие там WebGL, и я вполне обходился старыми до сегодняшнего дня? И всё прекрасно работало и безо всяких сообщений. 

Значится так - нужно сделать так чтобы в API был флаг, который позволял отказываться от новых фич (а не только от этого ужасного сообщения)

В Яндексе не слышали про обратную совместимость?

Расскажите, пожалуйста, каким образом предложение обновить браузер является нарушением обратной совместимости.

да как-то только вы (Яндекс) такой левизной страдаете... больше никто.

Архитектора не пробовали менять?

И ещё: нужно просто писать на сайте про то что в IE10 могуть быть какие-то там ваши надуманные проблемы, а не выводить это у людей в браузере. Это и есть нарушение обратной совместимости. 

Я архитектор API Карт.
Спасибо за ваше мнение, мы обязательно учтём его при дальнейшей разработке.

Хорошо что попало куда нужно.