Клуб API Карт

API Яндекс.Карт версия 2.1.29

ymapsapi
3 августа 2015, 15:39

Сегодня мы опубликовали новую версию API Яндекс.Карт 2.1 — 2.1.29. Она доступна по адресу api-maps.yandex.ru/2.1.29/?lang=ru-RU. В течение дня на новую версию также переключится api-maps.yandex.ru/2.1-dev/?lang=ru-RU.


Добавлено:
— Поддержка новых браузеров: Microsoft Edge и Firefox для Android.


Исправлено:
— Сдвиг координат опорных точек при построении мультимаршрутов с включенным обратным геокодированием.
— Проблемы с событием «click» на некоторых Android-устройствах.


Команда разработчиков API Яндекс.Карт

14 комментариев
Подписаться на комментарии к посту
когда примерно ожидать поддержку кластеризации неточечных объектов в ObjectManager?
ObjectManager поддерживает неточечные объекты, но
с кластеризацией они пропадают
http://clubs.ya.ru/mapsapi/replies.xml?item_no=57159

  Когда наконец перестанет меняться поведение предыдущих стабильных версий API при выпуске новой?

  Опять появилась ошибка: http://clubs.ya.ru/mapsapi/replies.xml?item_no=56377. Теперь уже на версии 2.1.22.

Всеволод Шмыров
4 августа 2015, 14:05
Добрый день.
Сейчас ошибка точно такая же, как и в сообщении? Не работают опции "iconImageClipRect" и "imageClipRect"?
Всеволод Шмыров
4 августа 2015, 14:28
Сейчас перепроверил. С imageClipRect действительно не работает, но работает с iconImageClipRect. Это ожидаемое поведение, так как остальные опции иконки тоже задаются с префиксом icon*. Видимо до 23й версии был баг связанный с тем, что опция работала без префикса.

Да, проблема была с префиксом (нашел сам).

 

НО, если версия вышла/застабилизированна, то ее поведение больше НИКОГДА не должно меняться. А у вас это происходит постоянно.

Еще, например, меняются названия стилей было ...-1-22-..., стало ...-1-27-...(потом, ...-1-29-...), хотя явно подключается библиотека версии 2.1.22.

 

Пахнет это не очень.

Ребята, вы собираетесь исправить лажу выше?

Здравствуйте! Я не знаю кода, но заметил баг, возможно ли исправить?

В IE 8-11 не работают яндекс карты встроенные на сайты (к примеру cian.ru). Ошибка проявляется на очень многих компьютерах, с разным подключением к интернету, и разными версиями Enternet Explorer. Если новая версия не поддерживает IE, почему об этом нет уведомления? И ещё, можно ли настроить IE для нормального отображения встроенных в сайты я.карт?

Всеволод Шмыров
6 августа 2015, 11:50
Добрый день. А о какой ошибке идет речь? Любая версия API 2.1 поддерживает IE начиная с 8й версии.
Всеволод Шмыров
6 августа 2015, 12:03
Я посмотрел циан и несколько других популярных сайтов API. В IE11 все везде работает, а в IE8 все работает кроме Циана. Но это на их стороне. Судя по всему они отказались от поддержки IE8. На каких сайтах еще у вас воспроизводиться проблема? 

Тоже смотрел на других сайтах, действительно  работает. На циане нет предупреждения, что они не поддерживают IE8. Написал вам, потому что проблема совпала с обновлением версии я.карт. В любом случае, спасибо за информацию.

 

У IE есть ещё адская настройка "Режим совместимости" (Compatibility Mode). Её нужно отключать, особенно если вы сидите под IE8 в какой-нибудь корпоративной сети на работе.
Спасибо, на конец исправлена ошибка клика на Андроидах