Клуб API Карт

API Яндекс.Карт версия 2.1.65

ymapsapi
14 июня, 17:48

Мы выпустили новую версию API Яндекс.Карт 2.1.65. Для её подключения используйте адрес: api-maps.yandex.ru/2.1.65/?lang=ru_RU

Мы уже переключили на новую версию api-maps.yandex.ru/2.1-dev/?lang=ru_RU и вскоре опубликуем обновленную документацию.

Добавлено:
- Тип маршрутов «Такси» в панели маршрутов.
- Информация об ограничениях по ходу движения в балуне маршрута.
- Метод 'getTileStatus()' тайлового слоя, который возвращает статус загрузки тайлов подложки. 
- В данные сервиса Регионы добавлена информация о граничащих регионах для каждого объекта.

Исправлено:
- Метод 'getAllPoints()' модели мультимаршрута не возвращал via-точки, если маршрут не удалось построить.
- Карта иногда не загружалась после масштабирования через Pinch-to-Zoom на iOS.
- Обновление Геоссылки при изменении контента страницы. 
- Геоссылка неверно определяла цвет фона при выборе цвета текста.
- Оптимизация загрузки API.
- Правки вёрстки.

Команда разработчиков API Яндекс.Карт

5 комментариев
на этой версии стала валиться ошибка
ymaps.modules: redefinition of util.providePackage
при подключении немного кастомизированного модуля https://github.com/yandex/ymaps-pie-chart-clusterer после оригинальной копии этого модуля. т.е. получается, что модуль подключается на странице два раза и вот этот кусок кода вызывает ошибку (на предыдущей версии все работает нормально):
var e = {modules: t.ymaps.modules};
!function (t) {
if ("undefined" == typeof t && "function" == typeof require)var t = require("ym");
t.define("util.providePackage", ["system.mergeImports"], function (t, e) {
t(function (t, n) {
var o = n[0], r = Array.prototype.slice.call(n, 1), i = e.joinImports(t.name, {}, t.deps, r);
o(i)
})
})
}...
exetrimall,
 Подключайте только кастомизированный ymaps-pie-chart-clusterer. В вашем случае он и так полностью перезаписывал модули обычного.
flapenguin,
это очевидное решение. дваждый подключались модули по ошибке, которая теперь стала очевидной. Суть в том, что на прошлой версии это не приводило к падению JS на всей странице, а в новой версии - приводит.
В релизе был добавлен новый используемый домен maps.yandex.net. Но на сайтах есть же csp политики -_-
Сергей
Сотрудник Яндекса17 июля, 17:17
tom990,
Где у вас сломалось, можно пример?