Клуб API Карт

14 комментариев
Uncaught TypeError: Object #<Performance> has no method 'now' 
Сергей
Сотрудник Яндекса31 марта, 02:05
dmamel,
Добрый день, не могу воспроизвести проблему. Дайте, пожалуйста,  ссылку на сайт/jsfiddle где воспроизводится эта проблема.
А нельзя как-нибудь достучаться до старой ссылки 2.1?
dmamel,
 Если 2.1 не критично, то временно можно использовать 2.0 - там всё нормально работает: http://api-maps.yandex.ru/2.0-stable/?load=package.standard&lang=ru-RU
BrandFA,
Спасибо, 2.0. не прокатило. Используются какие-то фичи из 2.1.
Обновили юзерам браузеры.
BrandFA,
Спасибо)
BrandFA,
А вообще, вроде бы они уже поправили. Или у меня уже крыша едет. Но кажется заработало. Ссылка https://api-maps.yandex.ru/2.1/?lang=ru-RU, старый браузер, все ок.
В IE 11
--- cut ---
SCRIPT438: Объект не поддерживает свойство или метод "now"
Файл: 2.1, строка: 2, столбец: 13726
--- cut ---
Это там, где у вас .... function(e){var t=u.now() ...
Ну нельзя же так! Могли бы проверить на совместимость с актуальными браузерами, прежде чем переключать. :(
Сергей
Сотрудник Яндекса31 марта, 02:05
BrandFA,
Добрый день, не могу воспроизвести проблему. Дайте, пожалуйста, ссылку на сайт/jsfiddle где воспроизводится эта проблема.
Сергей,
пожалуйста:
Работает в Edge и  d IE 11: http://to.lcc.ru/yandex/2.0.html
Работает в Edge и не работает в IE 11: http://to.lcc.ru/yandex/2.1.html (в IE 11 вылетает на стадии инициализации вашего кода)
Обновлено 1 апреля, 23:11
Сергей
Сотрудник Яндекса2 апреля, 00:00
BrandFA,
Вы переводите браузер в режим совместимости с помощью строчки <meta http-equiv="X-UA-Compatible" content="IE=9" /> . Если её убрать, то всё работает.  Зачем вы переводите браузер в режим совместимости?
Сергей,
это не совсем корректный вопрос - раз переводим, значит есть на то необходимость. Вы лучше расскажите будет ли работать 2.1.61 в IE11 c <meta http-equiv="X-UA-Compatible" content="IE=9" /> и если нет, то где можно взять старый 2.1?