Клуб API Карт

Версия Yandex API

al-nov
5 октября 2016, 18:06

Уважаемый dimik!

Очень прошу помощи. Ранее уже обращался к Вам, но вопрос тогда так и не решил, сейчас опять к нему вернулся. Проблема с версией Yandex API. Вместо 2.1 работает 1.х. (как мне кажется). Проверил везде где можно было, прописано 2.1. Куда копать? Как точно определить какая версия используется? Возможно, и подключена 2.1... но 

ymaps.ready(function(){
        var map = new ymaps.Map("#kart", {
            center: [55.76, 37.64],
            zoom: 10
	
	
        });

не срабатывает. Тогда как

 YMaps.jQuery(function () {
	
        var maps = new YMaps.Map(YMaps.jQuery("#kart")[0]);
        maps.setCenter(new YMaps.GeoPoint(37.64, 55.76), 8);
})

работает корректно.

В документации прописано что jQuery в 2.1 не включается. Возможно из-за этого не работает?

2 комментария
Подписаться на комментарии к посту
Привет. Я вам уже писал, что код от версии 2.1 не будет работать при подклучении в script версии 1.0


Посмотрите актуальные примеры в песочнице. Там есть вкладка "mapbasics.html"
Используйте код подключения апи из него или см. документацию
"#kart" решетку писать не нужно

var map = new ymaps.Map("kart"