Клуб Яндекс.Поиска для сайта

Не видно результатов выдачи поиска

virtualstudio-ru
7 мая 2013, 22:06

Не очень понимаю что делать - на всех своих сайтах поиск прекрасно работал, а тут ни в какую не хочет выводить результаты отдельной страницей.

Где копать? http://gidpodarkov.ru - уже ифрейм для выдачи поставил - ничего не показывает, не понимаю, в чем косяк, выручайте!

11 комментариев
Вульбрун Дмитрий
7 мая 2013, 22:07

Ну вообще-то у вас страница http://gidpodarkov.ru/search_results/?searchid=2043408&text=test&web=0 отдает 404 - то есть страница не найдена.

Этот адрес (http://gidpodarkov.ru/search_results/) указан у вас в настройках поиска.

У меня тоже не работает выдача на сайте, хотя в процессе создания на Яндексе все работало. Сайт http://www.tezter.ru/ форма поиска в модуле справа, страница результатов выдается пустой: http://www.tezter.ru/?option=com_content&view=article&id=14 вроде, в настройках поиска все верно прописано... Не поможете? Спасибо заранее!

Вульбрун Дмитрий
16 мая 2013, 23:04

хм.. сразу не скажу, почему так. Попросим разработчиков посмотреть. Как поймем причину, сразу напишем.

Спасибо, буду очень признательна! А не может это быть связано с тем, что сайт еще не проиндексирован? (хотя странно: при создании поиска на сайте Яндекса ведь все работало, значит, дело не в этом?)

Вульбрун Дмитрий
17 мая 2013, 13:25

нет, это не из-за этого. Если поиск ничего не нашел, то должно выводиться сообщение "Ничего не найдено".

Ок, тогда жду ваших версий :)

Вульбрун Дмитрий
17 мая 2013, 14:49

на странице результатов во вставленном вами коде результатов есть ошибка. Там зачем-то есть переносстроки и неразрывный пробел ( ). Вылядит это вот так: http://screencast.com/t/meF5TWcPbbP

 

Этот кусок должен выглядеть вот так:

Блин, надо же)) удалила разрыв строки - все заработало!

Спасибо огромное, все отлично!

virtualstudio-ru
18 мая 2013, 12:07

да, этот адрес и почему он 404, когда его можно посмотреть просто набрав адрес я не понимаю

 

virtualstudio-ru
18 мая 2013, 12:20

Ну а это уже прямо не смешно - http://doma-iz-brusa-i-brevna.ru/search/?searchid=2052017&text=баня&web=0 404 ошибка понятно откуда - НЕТ такой страницы, есть http://doma-iz-brusa-i-brevna.ru/search/ и НА НЕЙ поиск должен выводиться, что я не так делаю?

Вульбрун Дмитрий
20 мая 2013, 10:38

cgi параметры ?searchid=2052017&text=баня&web=0 необходимы для работы поиска. Так что вам нужно разрешить использование этих параметров на сайте. Ну или хотя бы на странице http://doma-iz-brusa-i-brevna.ru/search/.